Confirmed: No HTC Sense 3.0 for older handsets

Only new devices can support the new UI

HTC has confirmed that Sense 3.0, the updated version of the Sense UI found on all HTC Android phones, won't be available on older HTC devices.

It comes as no surprise, as the company didn't seem overly positive about the port being possible when we spoke to them at the HTC Sensation launch earlier this week.

It hurts that the senseless confirmation was imparted by way of a tweet from the official HTC account, though.


In answer to a customer's query, the tweet reads, "Due to Sense's hardware requirements, only our newest devices (Flyer, Evo 3D, Sensation) will be able to support it."

So if you've just picked up an HTC Desire S or HTC Incredible S, we're sorry to tell you that it's already out of date.

Still, there's a chance that these handsets will get some elements of Sense 3.0, although whether these will include the 3D overlay for home screens, the new lock display or the new visual widgets remains to be seen.

Via Unwired View



News Editor (UK)

It's a perpetual challenge among the TechRadar staff to send Kate (Twitter, Google+) a link to something interesting on the internet that she hasn't already seen. As TechRadar's News Editor (UK), she's constantly on the hunt for top news and intriguing stories to feed your gadget lust. And having been immersed in the world of tech and tech rumours for more than six years, she can spot a photoshopped iPhone 8 image from 20 paces.