Google is set to drop support for old browsers from 1 August.

While the news is unlikely to trouble most Brits, if you are still using IE6 or IE7, Safari 3 or Firefox 3.5 (or older versions of the above) then you really do need to upgrade your browser before August.

If you don't, then you will lose some really key features in Gmail, Google Calendar, Talk, Docs and Sites.

StatCounter figures on browser usage worldwide suggest that around 17 per cent of global users need to upgrade to a newer browser.

Google wants to push support for new HTML5 tech, something that older browsers cannot run, hence the shift to the focus on the latest versions of Google Chrome, Mozilla Firefox, Apple Safari and Microsoft Internet Explorer.

A necessity for the future

Venkat Panchapakesan, VP of engineering at Google, noted on the Google blog this week: "These new browsers are more than just a modern convenience, they are a necessity for what the future holds."

"For web applications to spring even farther ahead of traditional software, our teams need to make use of new capabilities available in modern browsers," wrote Panchapakesan.

"In these older browsers you may have trouble using certain features in Gmail, Google Calendar, Google Talk, Google Docs and Google Sites, and eventually these apps may stop working entirely," he added.

Amazingly, there are still 11 per cent of global internet users still regularly using Microsoft's IE6, with over a third of Chinese internet users still accessing the web via this out-dated browser.

Via Google