A Danish security firm has identified a "highly critical" security flaw in Adobe Photoshop . The problem affects PC versions of the newly released CS3 version of the software as well as CS2. However the company warns that other versions may also be affected.

Security firm Secunia says the problem affects the way Photoshop hands bitmap file types such as .bmp, .dib and .rle. If exploited, the flaw can lead to a buffer overflow problem. This in turn would provide a way for an attacker to gain access to a system.

Secunia's chief technology officer Thomas Kristensen says that no exploits have yet been found for the flaw. The company advises customers to refrain from opening bitmaps until Adobe releases a fix.