Compared to the recent mass-adoption of photo editing programs, spurred on by the digital camera revolution, vector-based drawing has become something of a lost art.

Steep learning curves and high prices for professional programs like CorelDRAW at £350, or the even pricier £570 Adobe Illustrator, are usually enough to put off all but the most serious computer artists.

Nice price

However, Serif has long been renowned for taking the financial sting out of traditionally high-priced creativity genres, offering powerful DTP and drawing programs at sensible prices. DrawPlus X2 is the latest in an illustrious line of the latter.

Fresh with Windows Vista certification, X2 is nevertheless backwards-compatible with Windows 2000 and XP operating systems.

A wide range of tutorials are arranged into two skill levels, catering to beginners and intermediate users, while two sets of projects are available to help you get the most out of the drawing and animation tools.

New tricks?

X2 now includes a new and highly helpful How To tab, supplying context-sensitive instruction for any selected tool, while you work.But brand new features are few and far between in X2.

Apart from Vista certification, the How To tab and some new tools for exporting animations to AVI, Flash and QuickTime, Serif has concentrated more on refining existing aspects of the program.

For example, the interface is a slicker and now includes options to save favourite workspace settings. Fills and effects are more varied and there are plenty of additions to the range of templates and galleries.

Like any drawing software, you really need a graphics tablet to get the most out of the program. Serif offers its own budget battery-free and cable-free GraphicsPad at £40, which is a decent piece of kit at the price, as well as a bigger, more up-market Wacom Graphire4 Classic XL tablet at £140.

Back on the software side, DrawPlus X2 offers genuine power and precision, and enough enhancements to make it worth the upgrade, even if you're still using Windows XP and don't need the Vista compliancy.